LightWave 2018

Page tree
Skip to end of metadata
Go to start of metadata

LightWave offers a bidirectional link between LightWave and Adobe After Effects CS5 and higher. This link can deal with cameras, lights and nulls. To set up After Effects to make it ready to communicate with LightWave, you need to activate full scripting features in After Effects.The default is for scripts to not be allowed to write files or send or receive communication over a network. To allow scripts to write files and communicate over a network, in After Effects choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS), and select the Allow Scripts To Write Files And Access Network option.


The other step you need to do is to copy the AEtoLW.aex file from LightWave2015/support/3rdparty_support/AfterEffects to your After Effects Plug-Ins folder normally found in Adobe/Adobe After Effects CS5 (or higher).

In Layout the AE link is on the I/O tab in Layout where there are two buttons.

Send to AE sends your scene to After Effects and the Settings button allows you to change the path After Effects is installed on after the first use where you are asked for the path. If you have multiple versions of AE installed select the one you want to use with the Settings button.

You can send multiple selected layers from After Effects to LightWave at the same time. Simply select the layers you wish to send in After Effects and use the File > Export > Send Selected Layers to LightWave.

Make sure your layers in After Effects and items in LightWave have unique names since it is those names that are used to match with LightWave scene items.

 

 

Select your scene’s camera and hit the Send to AE button. If After Effects is not running it will start and your camera will appear in a new composition named Default. If After Effects is running the item(s) sent from LightWave will appear in the currently active composition. You can undo this action in After Effects.

 

Once taken to After Effects and modified, you can send the camera and reference nulls back to LightWave using the File > Export > Send Selected Layer to LightWave 3D menu item. Make sure you have the After Effects camera selected for this to work. LightWave will appear with a camera with a baked motion path. You can repeat the same operation with reference nulls if you have any. Be aware that as of this time, only one item at a time can be sent.

If required, you can reset the path to LightWave in After Effects using the Edit > Preferences > Reset Path to LightWave 3D menu item.