LightWave 2018

Page tree
Skip to end of metadata
Go to start of metadata

Content Directory

LightWave's content directory system is an essential part of how scenes are constructed in LightWave 3D. All content consists of a scene containing objects (either geometry-based or procedural), surfacing for said objects (again, image-based or procedural) and all the animation, lighting, and other information necessary to recreate how a scene is intended to render final images - the end goal of creating a scene.

LightWave defaults to looking in certain directories under the Content Directory when you load scenes, objects, surfaces, images, envelopes, motions, previews, etc. This defaults to the user documents folder for the machine you installed the LightWave software into. The Content Directory is LightWave’s master directory; LightWave expects to find all of the appropriate subdirectories within this master directory.The Content Directory allows you to create a truly portable LightWave scene, including all object and image files and essentially acts as a pseudo root directory. By saving all your object and image files in subdirectories below the Content Directory, your LightWave scene and related files can be moved from drive to drive, from system to system, and even platform to platform, and still load properly.

Portability is important because LightWave scenes are often rendered on multiple machines or shared for education or fun.

If you use LightWave in a network environment, it is imperative that you use the Content Directory correctly.

When you save a scene, LightWave tries to save only a relative link to image and object files. So an object stored on your hard drive as C:\MyProjects\StretchPrincess\Objects\Jo.lwo where the Content Directory was C:\MyProjects\StretchPrincess, would be saved in the scene file as only Objects\StretchPrincess.lwo.If you use objects or images outside of the Content Directory, those links are hard-coded (e.g., F:\Stretch\Princess\Jo.lwo). If you never move the scene and support files to another computer, the scene will load fine, but this isn’t the way you should do it.

If you load a scene where an object/image file cannot be found, a file dialog will appear, letting you manually locate the file. To prevent having to keep redirecting LightWave, save the scene once loaded and better use Package Scene to unite all elements into a content directory.

Like scenes, objects can also have linked files. These are usually Image Maps used for surface textures. The Content Directory concept is also relevant here. Using image files below the Content Directory will avoid loading problems.

If you make any changes to object surfaces, you must save the object file - a step separate from saving a scene.

To set the Content Directory:

Open the General Options Tab of the Preferences Panel (Edit > General Options) and click the Content Directory button. A file browser will open and you can navigate to and select the folder you wish to use as your Content Directory.

You can also choose Set Content Directory from the Edit button, or choose from among the Content Directories that you’ve used lately by using Edit > Recent Content Directories, or by using the keyboard shortcut Alt + F12.

You can also change it in Modeler, on the General Options Panel. (If the Hub is active, Layout and Modeler will sync any changes to this setting.)

Ways to Use the Content Directory

Here are a couple of different ways to use the Content Directory feature:

  • Use a separate directory as the Content Directory for every project. You’ll need to create subdirectories for Objects, Images, and Scenes beneath it. All files relevant to the project would be stored here. As you change from project to project, you must also change your Content Directory. (Note that your project could contain a multitude of scenes.)
  • Create subdirectories called MyProjects in the Objects, Images, and Scenes subdirectories that are created when you installed LightWave. (e.g., C:\ Lightwave\ Objects\ MyProjects, C:\ Lightwave\ Images\ MyProjects, etc.). Then, for each project, create identically named subdirectories in each of the MyProjects subdirectories and store your files accordingly.

Be aware that LightWave will happily use either system, but that housekeeping is easier with the first option.

Production Data Files

Subdirectories other than Images, Objects, and Scenes (e.g., Surfaces, Motions, etc.) are generally important only during the production stage. The information from these files is incorporated in the scene or object files and is not tracked independently. For example, when you apply that cromulent silver surface file to your spaceship’s skin, the settings are saved in the object file. The surface is not referred to again, unless you use it again.

In Layout’s File Menu, Package Scene can be used to collect a scene’s supporting files and ensure correct compliance with your content directory.