LightWave 2018

Page tree
Skip to end of metadata
Go to start of metadata

LightWave has long had its own system of dynamics and they are presented here. They can sometimes interact with the more modern Bullet dynamics though they often require their own calculation or perhaps saving as MDD files. For most purposes, Bullet will provide better simulations and largely supersedes the original FX dynamics. As of LightWave 2018, there is still no Bullet equivalent for LightWave’s own particle emitter, which means that you should be familiar with the Particle Emitter at the least.

Adding Dynamics to your Scene and Objects

Items: Add: Dynamic Object

One way to quickly add dynamic objects to your scene is to use the Add Dynamic Object drop down list (Items > Add Dynamic Obj). Choose between Collision, Wind, Gravity, and Particle from the drop down menu. You can add one or more of these controllers to your scene. Then, each can be set with its own Parameter settings to create just the effect you are looking for. A dialog prompts you for a name when you add a dynamic object. Click OK to accept the default or type in the name you wish to use and click OK.

  • Collision - The Collision controller lets you add an element for the particles and/or dynamic objects in the scene to bump into (does not work with Bullet dynamic objects).
  • Wind - The Wind controller lets you add wind to blow your particles and/or dynamic objects around (does not work with Bullet dynamic objects).
  • Gravity - Add a Gravity controller to add gravity-like effects to your particles and/or dynamic objects motions (not needed for Bullet dynamic objects).
  • Particle - The Particle Emitter controller is the controller and the source for particles. There are two emitter selections: HV Emitter, which adds a HyperVoxels Emitter to the scene, and Partigon Emitter, which adds an emitter of single point polygons (“partigons”) to the scene

FX Browser

The FX Browser Panel is where you can add various controllers. From here, you can also open the property panels for the controllers that you add. To open this panel, choose Utilities > Additional > FX Browser.

To add an FX controller:

From the Add pop-up menu, choose the controller you wish to add, load, or apply.

FX controllers can also be applied to an item in the Dynamics Tab of the Object Properties Panel.
When you add a controller from the FX Browser that is not one of the “Apply” options, a null object is added to the scene. Then, an FX custom object plugin is added (e.g., FX_Emitter, FX_Wind, etc.). Just check out the Dynamics Tab of the Object Properties Panel.

To delete a controller:

Select and clear, just as you would any other Layout item (Items > Clear Selected or - on the numeric keypad).

To open a controller’s property panel:

Choose the controller from the Item pop-up menu and click the Property button to open the Properties Panel for the selected controller.

You can also display the Property Panel for the currently selected controller by choosing Utilities > FX_Property or by accessing the Dynamics Tab in the Object Properties Panel.
You can open multiple property windows, one per dynamic type, by holding Ctrl then changing the selection in the Item Select Menu.

The Start Button

Some effects require a “pre-calculation” before they can be previewed in your animations. These are instances where you have particles interacting or have post-deformed geometry. By activating the Start button, the FX will begin solving any simulations that are currently setup in the scene. The progress of the simulation is displayed in the output pane located at the bottom of the Particle FX Browser. A shortcut to this is on Layout’s toolbar at Modify > IKB Calculate.

Many scenes don’t need this step, but clicking Start won’t do any harm if you are unsure.

The Save Button

Clicking the Save button saves all controller motions, using individual files, to your FX directory (defined on the Option dialog). These can be loaded using the Load Motion option on the Controllers Properties Panel.

Options Dialog

The Options dialog has some options that affect the manner in which LightWave computes controllers.

The Background Job option activates multithreading. The update by Background Job option will update Layout when background tasks are complete. In most cases, you should leave these options in their default state of off.

The Resolution setting adjusts the parameter used when performing the physics simulations. The smaller the Resolution setting is, the more accurate the simulation will be. However, this also has a direct effect on the rendering times.

In this dialog you can also set the FX Directory. This is the default directory used when saving Controller settings.

Real-time Display

Just click the Play button in Layout and as you tweak the various controller parameters, you get real-time updates of how your changes affect the particles.

Scenes with particles interacting or with post-deformed geometry require you to click the Start button first to pre-compute some motions. Clicking Start won’t do any harm if you are unsure.

You can control how FX Controllers are updated using the UpdateMode pop-up menu.

Auto updates all emitters as parameters are modified. Use this for fast systems or in low-particle count simulations.If you have multiple emitters and are using the Select update, then only the emitter showing in the Select pop-up menu, if any, will be updated.

Adaptive dynamically scales the number of visible particles based on your CPU performance. This setting attempts to keep interactive performance at a useful level.

User turns off particle updating completely. You may force an update by either clicking the Start button on the Particle FX Browser, or the Update button on the File Tab of the Emitter Controller Panel. This setting is useful in situations with heavy particle counts.

Groups

You can group Dynamic objects with a user-defined name to prevent unwanted interaction. This also works with Particle FX controllers. This becomes very handy when you are working on a complex scene and you want certain Wind emitters to only affect certain objects.

  • <All Group> - Includes all groups.
  • <default> - Includes all items in scene.
  • <new group> - Create individual group. Can associate functions within a group.

You can associate particle FX’s functions by using groups. If multiple emitters are in the same group, you can associate settings. Also, if you do not want to associate, just by removing an emitter from the group, you can stop the association.

Object Properties: Dynamics Tab

Figure 1: Dynamics Tab, Add Dynamic drop-down menu.

The Dynamics Tab of the Object Properties Panel is where you can add FX Dynamics and manipulate their settings.

Add Dynamic

The Add Dynamic dropdown menu lets you select Dynamics to apply to an object.Add Dynamic choices:

  • Cloth - ClothFX , applies Cloth Dynamics to a target object.
  • Soft - SoftFX , applies Soft Body Dynamics to a target object.
  • Hard - HardFX , applies Hard Body (Rigid Body) Dynamics to a target object.
  • Emitter - adds a ParticleFX Particle or Partigon Emitter to the scene. Note that if you wish to add a HyperVoxel emitter rather than a particle emitter, you should use the Item: Add: Dynamic Object: Particles menu option to add the HV Emitter.
  • Wind - adds a Wind controller to the scene, which can be placed, sized and oriented to affect a specific portion of the virtual stage.
  • Collision - adds a Collision controller to the scene, which can be placed, sized and oriented to affect a specific portion of the virtual stage.
  • Gravity - adds a Gravity controller to the scene, which can be placed, sized and oriented to affect a specific portion of the virtual stage.

Dynamics List Window

Once you have added a Dynamics type and selected it, you will see controls for that dynamics type presented under the list portion of the Object Properties window. In addition, above the listview, on the right hand side of the window there will be a Calculate button.

Calculate

Clicking on the Calculate button will perform the dynamics calculations for the scene. If the FX Browser is not open, please note that if you change focus to another application or attempt to move the Object properties panel, the viewports will stop tracking the dynamics progress and stop refreshing. Layout will appear to be locked up, but the calculations are continuing, and the interface will refresh again when they are complete. Having FX Browser (Utilities/Plug-ins/Additional/FX Browser) open during calculations is therefore recommended to avoid the appearance of a lockup.