LightWave 2018

Page tree
Skip to end of metadata
Go to start of metadata

LightWave’s Layout has been designed to provide the most efficient interface possible for your 3D animation work. By default, there is a single large viewport, but you can display multiple viewports if you desire. A viewport provides you with visual feedback about the virtual world you are creating. How well this corresponds to what the final output will look like is completely configurable by you. This can range from bounding box stand-ins to wireframe representations, all the way to textured and solid-shaded displays. How you view your creations will vary depending on their complexity, your machine’s capabilities, and other factors.

1. Top Toolbar, 2. Layout Tabs, 3. Modeler Access, 4. Toolbar, 5. Workspace, 6. Numeric Adjustment Controls, 7. Grid Display, 8. Start Frame, 9. Timeline, 10. Tooltips, 11. Current Item, 12. Item Picker, 13. Item, 14. Properties, 15. Selected, 16. Key Section, 17. End Frame, 18. Transport Controls, 19. Preview, 20. Undo/Redo, 21. Rate/Step

1. Top ToolBar


The Top Tool Bar buttons will appear no matter which Tab is selected and contains elements that are always required, such as File and Edit menus. You can completely hide (or unhide) the toolbar by pressing Alt +F2 (or choosing Edit > Display Options > Hide Toolbar On/Off).

2. Layout Tabs


The tabs located at the top of the interface will determine which tools appear in the Tool Bar. Generally, menu group names that are verbs contain commands based on the type of action they perform. Menu group names that are nouns contain commands based on the type of object they affect. The menu tab names are all intended to be read as verbs.

  • Items - Things to add to your scene, such as objects, lights or cameras
  • Modify - Animating scene items
  • Setup - Rigging and related tools
  • FX Tools - SimulationFlocking and Fiber FX
  • Render - Setting up and starting scene or image renders
  • View - Tools for organizing viewports
  • Model - Creating quick geometry inside Layout
  • I/O - Working with other applications such as After Effects, ZBrush and others
  • Utilities - Plugins and scripting

Note also that when in VPR mode there is an additional dropdown listing buffers to render.

3. Modeler Access


This command will switch to your Modeler window if it is open or opens Modeler if you do not already have it open.

4. Toolbar


The buttons presented in this toolbar will depend on which menu tab you select along the top.

5. Workspace


The Workspace consists of Viewports. By default, there is a single large viewport, but you can display multiple viewports if you desire (using the F3 and F4 keyboard shortcuts or visiting Options > Display). A viewport provides you with visual feedback about the virtual world you are creating.

Viewport Titlebar


You can change the View Type and Rendering Style of a viewport without going to the Display Options Panel by using the pop-up menus on the left side of each viewport titlebar. You can also activate Weight Shade and Bone X-ray modes.

The buttons on the right side of a viewport affect centering, panning, rotating, zooming, and minimizing/maximizing your view.

6. Numeric Adjustment Controls

You can change Position and Rotation settings numerically by entering the desired values in the XYZ or HPB fields, located in the lower left corner. The function of these fields changes depending on the editing being done.

Protecting from Changes

Whether you are moving, rotating, or stretching an item, or moving its pivot point, Layout lets you independently deactivate any of the three components used for those settings. You deactivate the components by clicking on them on the information display in the lower-left corner of the screen. This protects the deactivated component(s) from changing as you move your mouse.

The Y channel won’t be affected when moving the currently-selected item.

You can also confine changes by using any of the orthogonal views (i.e., Front, Top, and Side). In these views, you can generally make changes only along the display’s horizontal and vertical axes using your mouse.

7. Grid Display


The grid serves as a visual reference when you move items around, but it will never render in a final image (no matter how much you wish it to). The grid lines are darker every tenth square for visual reference. The Origin is located at the center of the grid.

You can find the current size of the grid squares in the information field at the very lower-left corner of the screen. The size of each grid square is adjustable as is its overall size on the Display Options Tab of the Preferences Panel (Edit > Display Options). If you adjust the size of the grid squares you also adjust the relative size of the camera and the lights within the scene.

8. Start Frame


This displays the first frame of the scene. It can be raised or lowered. This number remains in frames, even if you should set the timeline to be displayed in one of the other options (SMPTE, Film Key, Seconds) in the Options window. By default it is set to 0. If you wish to offset the Start Frame by default visit the Defaults tab in Preference.

 

9. Timeline and Dope Track


The Timeline, located beneath the viewport area uses the Frame Slider which can be dragged to change the current frame or shuttle through your scene. The input field to the left of the timeline is the first frame in your scene and the input field to the right is the last frame. You can change these settings by simply changing the values in either field.

The DopeTrack allows you to modify keys. You can adjust not only their position in time and the scene, but also alter their properties. You can set up markers here to tell you when things should happen in the scene and bake ranges of keys to make your animation concrete. You can open or close the DopeTrack by clicking on the thick bar above the time line.

10. Tooltip


This line of the interface shows information about tool actions or potential actions, and the render time for VPR as shown.

11. Current Item


This dropdown menu changes depending on the type of item you have chosen (13). You can choose between Objects (including dynamics), Bones (contained within objects - choose the object containing the bones first, then switch to Bone mode), Lights and Cameras. These items are exclusive, you cannot select a camera at the same time as an object.

12. Item Picker

The Item Picker window allows you to quickly select one or more objects and to set up selection sets of objects for faster use.

13. Items

As mentioned above you can only choose items from one of LightWave’s four groups at the same time. You can switch between the groups with these four buttons.

14. Properties


This button brings up a Properties window for the four item types. There’s a window for Objects, one for Bones and Lights and Cameras share a window.

15. Selection Info


The Selection Info displays how many items are selected.

16. Keyframe options


To automatically create or modify keys you must activate the Auto Key option on the main interface. This is the global on/off switch for automatically creating keyframes. It works in conjunction with the Auto Key Create setting (General Options Tab of the Preferences Panel).

Use the Create Key and Delete Key commands to add and remove keyframes.

17. End Frame


This displays the last frame of the scene. It can be raised or lowered. This number remains in frames, even if you should set the timeline to be displayed in one of the other options (SMPTE, Film Key, Seconds) in the Options window.

18. Transport Controls


Besides dragging the frame slider to navigate through your scene, you can also use the transport controls.

19. Preview


You can create a previsualization of your scene for when playback in Layout is not fast enough.

20. Undo/Redo


The Undo function will reverse motion changes (Move, Rotate, Size, or Stretch tool) that you have made. The Redo function will re-execute a sequence of actions that have been undone, beginning with the action most recently undone. You can set the number of undo levels that you wish to have available in the General Options tab of the Preferences Panel, discussed later, in the Edit Menu section. If there are no actions available to undo, the Undo button will be ghosted.

The Redo button is ghosted if there are no actions available to redo.

If you are not using the Auto Key feature, you can quickly reset all aspects of a frame (i.e., position, rotation, etc.) if you haven’t created the key yet. Just press the Right cursor key and then the Left cursor key. This advances the current frame and then goes back to the original frame. The frame will return to the last keyframed state, or if the frame is not a keyframe, to its in-between state.

21. Rate/Step


This value sets the speed of playback. If you have the option Play at Exact Rate checked in Options then this field will be labeled Rate. If not, it will be labeled Step. Rate is a percentage of real time, while Step is what frames will be played - 1 indicates every frame, 2 indicates every other frame, 3 indicates every third frame and so on.