LightWave 2018

Page tree
Skip to end of metadata
Go to start of metadata

Clearing Configs

If you are required to clear configs for any reason, the way to do it is to make sure LightWave is closed, including the Hub application (in your Windows task bar or Macintosh dock). Then, navigate to:

Windows

<user>\.NewTek\LightWave\2018.0

and delete

Extension Cache-64
LW2018.0-64.CFG
LWEXT2018.0-64.CFG
LWHUB2018.0-64.CFG
LWM2018.0-64.CFG

Macintosh

 ~/Library/Application Support/NewTek/LightWave/2018.0/

and delete

Extension Cache
Extensions 2018.0
Hub 2018.0
Layout 2018.0
Modeler 2018.0

now when you launch anew, you can be sure everything in LightWave will be factory fresh.

There may be plugin configs and color picker configs still to clear. If you wish to remove all traces completely, delete the 2018.0 folder but be warned you will have to license your LightWave again (your license key can be retrieved from your account at http://lightwave3d.com).

Config Backup

When configs are changed now, a backup is created of existing settings before changes are enabled.

Edit Keyboard Shortcuts

(default keyboard shortcut Alt F9)

We strongly suggest that you keep the default keyboard mapping assignments and make new shortcuts only to unmapped keys. (Most of the function keys are open.) Otherwise, technical support and using the documentation may become difficult.

Like the menus, keyboard shortcuts can be configured to suit your needs. To display the Configure Keys Panel, choose Edit > Edit Keyboard Shortcuts.


The window on the left contains a complete list of all assignable commands grouped by type. The right window shows the full list of all keystrokes and assigned commands, if applicable.

To assign a command to a key

  1. Select a command in the left window.
  2. Choose the target key in the right window. (You can hit the desired key or keystroke combo to select the key quickly.)
  3. Click the Assign button. This will overwrite any existing assignment. Alternatively, you may drag the command to the right window.

To unassign a command to a key

  1. Select the target key in the right window.
  2. Click the Unassign button.

Finding Assignments and Commands

If you have a command selected in the left window and click Find, the command, if any, on the right will become selected. Choosing a command in the right window and clicking Find will select the matching command in the left window.

Clicking Search allows you to type in a search phrase to find a command. Search is case-sensitive. This will find the first instance when first run, and can be used iteratively to find additional instances by just hitting the button again, as it retains the string until you type in a new one.

Keyboard shortcuts can be assigned to only one command. Assigning a command that is already assigned to a different key will assign it to the new key, but remove it from the old one.

Maintaining Key Mapping Sets

The Load and Save buttons let you retrieve and store key mapping sets that you develop. The Clear button clears out all assignments, so use with caution. Any available preset key mapping sets can be chosen from the Presets pop-up menu. The Window pop-up menu lets you select different menus to edit (e.g., Graph Editor), if available.

Edit Menu Layout

(default keyboard shortcut Alt F10)

We strongly suggest that you keep the default menu organization intact. Otherwise, technical support and using the documentation may become involved. A better solution is to create a new menu tab and/or groups and place your frequently used tools in them.

LightWave menus are customizable. You can add, remove, group, and reorganize commands.Choose Edit > Edit Menu Layout to open the Configure Menus Panel.


In the (left) Command window, a list of available commands will appear. These will be grouped by type.

In the (right) Menus window, several main sections have sub-items, which are indented to show the hierarchical relationships. Top Group contains the items that are always visible no matter which tab is selected. Main Menu items are the main tabs and related buttons for the main interface toolbar. Left, Middle, and Right Mouse Button Menu (when available) are the menus that appear when the Shift + Ctrl keys are held down along with the corresponding mouse button. There may be other menu sections defined.

In the Menus window, dots indicate commands while arrows indicate groups of commands/sub-groups beneath it. If the arrow points to the right, the group’s sub-menu items are collapsed and not visible. To reveal the sub-menu items for a collapsed group, just click on its right-facing arrow. To collapse an open group, click on its downward-facing arrow.

Finding Assignments and Commands

If you have a command selected in the left window and click Find, the command, if any, on the right will become selected. Selecting a command in the right window and clicking Find will choose the matching command in the left window.

Clicking Search allows you to type in a search phrase to find a command. Search is case-sensitive. This will find the first instance when first run, and can be used iteratively to find additional instances by just hitting the button again, as it retains the string until you type in a new one.

Menu Branches

Menu branches can be exported and imported allowing for rapid customization of several menu entries. To export a menu branch, right-click over the group you wish to export and choose Export Branch.

The file saved can be loaded into a different installation of LightWave using the same method - right-clicking the area in which you wish to import a menu branch and choose Import Branch.

New to LightWave 2018 is an additional command Import and Replace Branch.

Maintaining Menu Layouts

The Load and Save buttons let you retrieve and store menu layouts that you develop. Any available preset menu layouts can be chosen from the Presets pop-up menu. The Window pop-up menu lets you select different menus to edit (e.g., Graph Editor), if available.

Edit Plugins Command

(default keyboard shortcut Alt F11)

Use the Edit Plugins command to review and delete plugins that have been added. In Modeler, choose Utilities> Plugins > Edit Plugins.

To delete a plugin command

You can delete a plugin command by selecting it and clicking the Delete button. (Other commands from the plugin will continue to exist.) Click Clear to delete all plugins listed. These operations have no effect on the actual files stored on your hard drives.

To rename a plugin command: You can rename a plugin command’s name by selecting it, clicking the Rename button and entering a new name.

You can also add plugins on this panel. The Add Plugins and Scan Directory buttons operate the same as they do for the Add Plugins Panel, discussed earlier.

File Grouping Method

If desired, you can list the Plugin commands by their .p plugin filenames. Just select the File Grouping Method button at the bottom of the Edit Plugins Panel.

Window Config Loader

This command is a quick way to launch a window configuration that was generated by the Window Configure tool.

Scene Metadata

If your pipeline dictates that you need to use a different path structure for use with other applications, it can be awkward when you need to bring scenes back into LightWave for further editing, needing to tell LightWave where a projects images are for instance because you have them under a different path. You can now save metadata to a scene file as comments if your workflow dictates that you vary from the standard LightWave content directory structure of Images, Objects and Scenes.

When saving out a scene file, append the content directory information as comments to the very end of the scene file.

If Use Custom Paths is left unchecked, this should be a single comment like this:

// ContentDir: "X:/project/_library/assets/LW_Content"

If Use Custom Paths is checked in your LightWave options Paths tab, append all of the custom paths as comments to the end of the LWS file as well:

// ContentDir: X:/project/_library/assets/LW_Content
// ObjectsDir: X:/project/_library/assets/LW_Content/Objects
// ImagesDir: X:/project/_library/assets/LW_Content/Images


The full list of custom path is as follows:

ContentDir "X:/project/"
ScenesDir "X:/project/Scenes"
ObjectsDir "X:/project/Objects"
SurfacesDir "X:/project/Surfaces"
ShadersDir "X:/project/Shaders"
ImagesDir "X:/project/Images"
PreviewsDir "X:/project/Previews"
MotionsDir "X:/project/Motions"
EnvelopesDir "X:/project/Envelopes"
AnimationsDir "X:/project/Animations"
NodesDir "X:/project/Nodes"
SoundsDir "X:/project/Sounds"
DynamicsDir "X:/project/Dynamics"
RigsDir "X:/project/Rigs"
LightsDir "X:/project/Lights"
RadiosityDir "X:/project/Radiosity"
ColorTablesDir "X:/project/ColorTables"
ImageCacheDir "X:/project/ImageCache"
VertCacheDir "X:/project/VertCache"
BackupDir "X:/project/Backup"

Interface Color Customization

Customizing the Interface colors for Modeler and Layout is accessed through the Options panels in both applications - the Display tab in Layout and the Display Options Interface tab in Modeler. You will need to restart LightWave to see the changes you have made.


Configuration Files

For Macintosh OS X, the LightWave configuration files are stored in your ~/Library/Application Support/NewTek/2018.0 folder like so:

  • Extension Cache
  • Extensions 2018
  • Hub 2018
  • Layout 2018
  • Modeler 2018

For Windows 7 and onwards, the configuration files are kept in <USERNAME>\.NewTek\LightWave\2018.0. They are named:

  • Extension Cache-64
  • LW2018-64.CFG
  • LWEXT2018-64.CFG
  • LWHUB2018-64.CFG
  • LWM2018-64.CFG

Generally, you will not need to edit these files directly, however you might need to remove these files if they get corrupted.

Startup Options

The following options are described for use in Windows. At the end of the list of Startup options there is an Info box for Macintosh OS X.

Editing a shortcut's target path can add functionality to how LightWave starts up. Here shown, -d for startup content assignment

In Windows, shortcuts need to be edited for both the Modeler and Layout applications where appropriate for flags to take effect.

-c for Configs

If you wish to redirect where LightWave stores the configs it creates away from the regular C:\Users\<username>\.NewTek\LightWave\<version> folder, you can add -c to the end of your shortcut's targetline with the path chosen for the configs.

-d for Content

Layout has a -d option for designating a content directory to be used at startup. In Windows, it can be added as a startup option by editing the icon properties of the shortcut created for launching Layout and adding -d and the directory you wish to use, like so:

-p for Plugins

The -p option is for creating a different location for plugin files - useful for instance when running multiple copies of LightWave over a network with a central store of plugins.

-0 for Command IPC

Using the -0 commandline flag will not run the Hub but use an Interprocess communications system. Layout and Modeler all notify each other when a mesh file has been saved to disc, and the applications that have that file open and have not applied modifications during the session will update from the new version on disc. For example, if both Layout and Modeler have “bob.lwo” open, Modeler has some edits applied to it, and Layout saves it transformed, Modeler will not automatically update from the disc.

If subsequently the object is saved out from Modeler, that will overwrite the changes made by Layout, and Layout will update from the save if no further changes were applied in Layout during the interim.

-i for Isolate

The ‘isolate’ flag (‘-i’) will completely disable all IPC mechanisms (Hub and CommandIPC), leaving the application isolated from all other product actions.

Shortcuts should be made for Layout and Modeler, with the same flags applied in both. In all cases, there is no space following the flag for the path chosen. The example below is for redirecting configs:

C:\NewTek\LightWave_2018.0\bin\Layout.exe -cF:\Configs

--frame-end-beep

Use this flag to play an existing sound file when a frame finishes rendering. The syntax is as follows:

--frame-end-beep={sound_file}

--anim-end-beep

Use this flag to play an existing sound file when a frame sequence finishes rendering. The syntax is as follows:

--anim-end-beep={sound_file}

--preview-end-beep

Use this flag to play an existing sound file when a preview finishes rendering. The syntax is as follows:

--preview-end-beep={sound_file}

-f for Font

Use this flag to call a system font as the typeface to use for Layout or Modeler. The syntax is as follows:

-f{font_name@font_size}

Use the filenames for the typefaces you wish to use rather than the display names, but the extension is not necessary - Stencil Std Bold should be written as stencilstd (you can leave off the .otf).

Layout displayed with Stencil Std Bold at 10pt; Giddyup Std Regular at 12pt and Georgia at 9pt. The flags used were ...\bin\Layout.exe -fStencilStd@10; -fgiddyupstd@12 and -fgeorgia@9

--command-port

The --command-port option enables an operating system-based communication mechanism that allows external processes to feed LightWave Command Sequence commands directly into the LightWave application.  This allows real-time and continuous execution of CS commands within running LightWave programs.

The distributed LightWave product includes a Python package that works with both Python v2 and v3 that allows Python programs to utilize this mechanism.

When enabled, the command port number selected is displayed in the LightWave application's titlebar.  (e.g., "--command-port=45454").

This mechanism does not function with Screamernet.

(the command-port mechanism is somewhat reminiscent of the Amiga AREXX system LightWave used to support.)

--dpiaware

Described below.


OS X Specifics

For OS X, the procedure is more involved. Here is how to make an launch shortcut icon using AppleScript:

  1. Open the /Applications/Utility/AppleScript Editor.app application
  2. Choose to create a New Document.
    Enter the following text:
    do shell script "/Applications/NewTek/LightWave_2018/Layout.app/Contents/MacOS/Layout"
    (command line arguments should be added here, before the quote marks)

  3. Save the document as an Application to your Desktop.
  4. Double-click the resulting application icon.

To re-edit the resulting application, drag it to the dock "AppleScript Editor" icon.


HiDPI

When a Windows user has the resolution DPI set greater than 100%, LightWave's window contents expand and will appear blurry sometimes.

Launching LightWave with the "--dpiaware" argument will correct the size of window elements and make them sharper.

Although this helps make the GUI look readable on HiDPI monitors, it is not always the desired effect. Since LightWave does not truly support resolution independence for its GUI at present, giving the user the option is possible and desirable.

The screen on the left is without the --dpiaware argument, the one on the right is with the argument

Layout Startup Command

If the LW2018-64.CFG configuration file contains a line beginning with “StartupCommand,” Layout will try to execute the rest of the line as a command   after the main interface is first opened. The command can have arguments and it can refer to a generic plug-in or script.

Customizing Layout Viewport Navigation

The mouse directions used for viewport navigation can be customized by editing the WorldNavigation entry in the LW2018-64.CFG configuration file. It has four boolean values that correspond to panning via icon and Alt key, and rotation via icon and Alt key. Zero values mean that the viewpoint moves in the same direction as the mouse, and ones mean that the world appears to move with the mouse. For example, the default in LightWave 9 is 0 1 0 1. The old 5.6 setting would be 1 1 0 0.

Customizing Camera Presets

The camera resolution presets are stored in the LW2018-64.CFG configuration file using the keyword “ResolutionPreset.” Each preset includes a width and height, pixel aspect ratio, mask settings (left, top, width, and height) and a name that will appear in the pop-up menu. They can be modified, deleted, or added to. If no presets are found in the file, the original list is restored. See the configuration file for examples.

Customizing Image Savers for Output

Full image saver list reduced by removing plugins (Alias.p, Aura_Exporter.p, BMP.p, CineonFP.p, DPX.p, DRLA.p, IFF.p, PCX.p, PICT.p, RLA.p, SUN.p, TGA.p, VPB.p and YUV.p plugins removed for this example)


The standard LightWave Image Saver list in the Output tab is long, but can be reduced if certain file types are sure not to be needed. The plugins for this list can be found in the following locations, depending on operating system:

  • Windows: LightWave_2018.0\support\plugins\input-output
  • OSX: /Applications/NewTek/LightWave3D_2018.0/support/plugins/input-output

There are caveats with doing this:

  1. A backup of the plugins should be kept. Perhaps the easiest solution is to add the unwanted filetypes to the legacy.zip in the plugins directory;
  2. While this reduces the Output list it also cancels the ability for LightWave to handle removed filetypes for loading;
  3. Doing this might cause problems with some distributed rendering plugins.