Now that you have reviewed cameras, lights and objects in the Layout section, it’s time to discuss animation.

Keyframing

The way to tell the computer where an object - be it camera, models or lights - is at any given point is to use keyframes. Keyframes fix an object’s location, rotation and scale for a given moment in time. Setting one at the start of your animation and one at the end means that LightWave will automatically interpolate between them for the duration of the animation. In fact it will create these in-between frames, called tweens, between every keyframe resulting in a fluid animation. To get you started, let’s create a piece of the easiest animation possible.

 

  1. Start Layout and check to see if Auto Key: All Channels is enabled at the bottom of the interface window. Add a cube by clicking on the Modeler Tools > Create > Geometry > Cube button and accept the default entries by hitting the OK button. The cube will appear at 0, 0, 0.

  2. Click in an empty part of the viewport and move the mouse. You will see the cube moves since it is the selected object. If you wish to restrict movement to an axis, hit Ctrl Z to undo your move and click and hold on the red arrow indicating the X axis. Drag the cube over to the left side of the screen.
  3. Move the slider at the bottom of the Layout viewport to the end of the slider range - it will be at frame 120 by default. You can also do this by clicking on the rightmost button of the transport controls under the viewport.
  4. Move the cube over to the right edge of the viewport, either by the X axis arrow or just freehand in the viewport. You will see two things. The first is that there’s a yellow line on frame 0 in the timeline under the Layout viewport (there’s also one under the slider at frame 120 now, but it won’t be as visible), the second is that there’s a gray dotted line marking some of the path that the cube is taking. If you were to count the dots when the cube is at frame 60 by hand, you would see that there were 120 dots - 60 in front, 60 behind, but just take our word for it. These mark frames along the way.
  5. If you hit the play button just under the right-hand side of the Layout viewport you will now see your cube moving across the screen and starting again when the slider reaches the end of the timeline. Congratulations! You’ve made an animation. It’s not exactly Disney caliber, but it is an animation.
  6. To make it slightly more interesting, stop the playback by hitting the pause button. Move the timeline slider to the middle of the timeline.
  7. Move the null up to the top of the viewport. You can do this by grabbing the green arrow pointing upwards from the null, or by using the right mouse button anywhere in the viewport. You will see the motion path change to match the new keyframe. Now when you press play again, you can see that LightWave has taken note of your changes and made the appropriate in-between frames for the motion to proceed smoothly.
  8. Stop playback by hitting the Pause button and go through your scene adding more keys as you go. Create a real roller-coaster ride for the Cube to take.
  9. When you want to check the null’s motion path, press play. When your viewport is in Perspective mode, if you use the navigation controls at the top right of the viewport, you can see how the animation looks from any angle. See something you don’t like? Press pause, move the timeline slider to the frame you want to change and move the cube.
  10. All items in a LightWave scene can have independent keyframes - while your cube is getting sick on its roller-coaster ride, you can have the light in the scene changing direction and the camera following it around to make it even more disoriented. Even better, just because you’ve keyframed an object’s heading, there’s nothing to say that you can’t keyframe its pitch and bank on different frames.
  11. Go back to our short tutorial and get everything - and I mean everything: cube, camera, light - moving. Don’t forget that in addition to the Move tool you used to reposition the null, you also have the Rotate tool (keyboard shortcut: Y ) and the Size and Stretch tools (keyboard shortcuts: Shift +H and H). You’ll find all these tools on the Modify Tab or you can just roll the mousewheel. We’re not looking for great art, just trying to get you used to how things work.

Normally speaking, LightWave doesn’t work in seconds because motions tend to be too quick and seconds too coarse a measurement. It works in frames - there are 25 to a second in PAL and 30 frames to a second in the NTSC TV system, HDTV is more complicated, varying between 24 - 60 fps. For film work, there are 24 frames to a second. If you’ve left your time settings at standard they will be at 30 fps and you have created four seconds of animation.

Keep working on your simple animation until you start to feel the cube’s pain at being forced to ride the roller-coaster one more time… This is easy and you’ll be glad you’ve practiced before things start getting harder.

Navigating a Scene

Just under the Layout viewport (or viewports) is the frame slider that we’ve already used for our exciting null animation. Although its main action is obvious, you also have the ability to change the range shown and also to pan through this range easily. To scrub through the frames you can move the slider with the mouse or you can use the cursor keys.

Left and Right move you through the frames one at a time, and holding down the Shift key at the same time moves you to the previous or next keyframe. If you hold down the Alt key while you move the slider with the mouse you will pan the frame range – this means that you will keep the same number of frames on the slider, but the start and end points will change accordingly. If, for instance, you had a 500 frames long animation, the amount of action would cause the detail in the frame slider to be confused. But if you set the end frame to a 100, you can then pan through the other 400 frames of your animation, so this 100 frames could show the range between 0-100, or 357-457, as you like.

You can also jump to a specific frame in your scene by hitting the F key on the keyboard, which will bring up a requester where you can enter a frame number.

Playing a Scene

Under the transport controls for the scene, you will see two playback arrows and a Pause button, and under that a Step counter. The playback arrows allow you to playback the scene in either direction while the step counter allows you to set how many of the scene’s frames you wish to see played back. Setting this counter to 1 will play every frame, setting it to 2 will play every other frame, and so on.

Make sure your scene is not playing back before you move anything. If you have AutoKey on, you will end up with keyframes all through the animation.


Your playback speed will vary depending on the complexity of your scene, object display mode, system capabilities and so on. Reducing the size of your Layout window can dramatically increase playback speed.


If the Hub active, you can modify an object in Modeler even while your scene is being played back in Layout and the object will automatically update to reflect the changes you make.

Creating Keyframes

As we’ve already learned, objects are always loaded at the Origin. This is the center of Layout’s grid: 0, 0, 0 and every new item will have a default keyframe for frame 0 here. If you never create another keyframe for an item, it will stay at this default location throughout the animation.

Frame 0 is the default starting point, but you can create keys at frames less than 0, if you need to.

We used Autokey in the tutorial at the start of this section, but if we turn it off we will need to set keys by pressing the Return key twice. A window appeared but was dismissed by us hitting the return key the second time. Let’s go in for a closer look at this window.

By default the Create Key At field will contain the current frame. You can change the frame number to create the key - using the animation channel values for the current frame - at a different frame by entering a different frame number here. This is a good way to copy a keyframe. You can also re-pose your item and create a new key over an old one.

The For pop-up menu has several options. You can create keys for:

Selected Items - All items that are selected, which will always include the current item. Generally, this will be the one you use the most.

Current Item Only - Only the current item, even if others are selected.

Current Item and Descendants - The current item and any child items.

All Items - All items in the scene. Beware that this is not limited to just items of the same type. A key will be created using the current Animation Channel settings for all objects, bones, lights, and cameras.

The dialogs for creating motion keyframes for scene items have three rows of Toggle buttons. This lets you create animation channel keys independently. The Position, Rotation and Scale buttons allow a row to be turned on or off with one click. All channels are enabled by default and their state is remembered.

Keys created using the Create Motion Key dialog use the Graph Editor’s Default Incoming Curve type, discussed here. Generally, we suggest you use TCB Splines and not Bezier Splines. Bezier tangents are determined at the moment of creation and don’t automatically adjust as new keys are created. This can cause awkward movement through keys.

Creating and Modifying Keys Automatically

To automatically create or modify keys you must activate the Auto Key option on the main interface. This is the global on/off switch for automatically creating keyframes. It works in conjunction with the Auto Key Create setting (General Options Tab of the Preferences Panel).

Auto Key is a time-saving feature for advanced users and can be very useful for quickly roughing out a motion path; however, beginners may want to stick with creating keys manually.

Make sure you are always aware of the status of Auto Key and Auto Key Create. These options can result in an animation with extraneous keyframes.

The Auto Key function has been refined to allow quicker access to the various modes it can operate in. Previously this feature was hidden away in the Options panel, but is now located directly on the main interface in Layout. The Auto Key preference in the Options panel now only serves as a default startup preference.

An option also appears in the Auto Key popup menu called Auto Key: Existing. This mode was available before but was somewhat hidden; it has now been made much clearer which Auto Key mode you are in. The checkbox is now a visual indicator as to when Auto Key is active and when it’s completely off. Auto Key now has the following modes:

Auto Key: Off


Automatic Keyframing is completely off, no new keyframes will be created or existing ones modified.

Auto Key: Modifed


New keyframes will be created/modified, but only on the channels you edit. E.g. If you only move an item, keys will be created/modified only for the translation channels you change, but not for rotation or scale.

Auto Key: All


New keyframes will be created/modified on ALL channels regardless of whether you only move, rotate or scale an item.

Auto Key: Existing


Only existing keyframes will be adjusted, no new keys will be ever be created, this is to allow tweaking of keys without fear of ever creating new ones. In previous versions of LightWave this mode was available when Auto Key Create Default in Options was set to Off, but the Auto Key button in Layout was active. Now you just need to select this option.

Auto Key: Fixed

Keys will only be placed at the Auto Key Fixed Frame set in the field below the pop-up menu. Best used with static items that have no motion paths.

Note that the Autokey indicator at the bottom of Layout works in a similar manner to how the original Autokey on/off button did. For your Autokey preferences to be saved, you still need to visit the Options panel. This setting is not scene-specific.

Editing Motion Paths Directly in a Viewport

You can also move an item’s motion path directly in a viewport using the Move Path tool (Modify > Motion Path > Move Path).

The Move Path tool allows you to shift your completed motion path for an item, keeping all the keys in the same places relatively. Let’s say you had a very complicated scene, it would be useful to be able to move to an empty portion, create the motion path for your object and then move it into place. With Move Path, that’s exactly what you can do.

 

Deleting Keyframes

You delete keyframes in a similar way to how you create them.


To delete a keyframe:

  1. Select the item. Normally, you will also go to the keyframe you wish to delete.
  1. Click the Delete Key button at the bottom center of the Layout interface or press the Del key.
  1. The Delete Motion Key dialog will appear. It uses all of the same controls previously described for the Create Motion Key dialog.

Delete Motion Key Plugin

Use the TMP Motify Delete Motion Key generic plugin (Utilities > Additional > Motify) to delete keyframes, clear motions, delete ranges of keys, delete keys within a threshold, and more. Motify can be used to completely replace the built-in Delete Key dialog.

To use Motify:

  1. Select the item(s) you want to delete keyframes from. Normally, you will also go to the keyframe you wish to delete.
  2. Run Motify
  3. Choose a Delete mode.
  4. Enter a range of keys in the Delete Keys From and Through input fields.
  5. Enter a Threshold.
  6. Choose a For mode.
  7. Enable or disable channels
  8. Click OK.

Many of the above steps are optional. For example, to simply delete a keyframe at the current time (using the previous For mode), run Motify and click OK.

The For pop-up menu determines which objects will have their keys deleted and has several options. You can delete keys for:

The Position, Rotation and Scale buttons allow a row to be turned on or off with one click. Only the selected channels will be processed. You can Shift click to invert a group’s selection state.

The All Other Channels button is a powerful feature, but can cause a lot of damage to your scene if used incorrectly. All non-motion channels will also be processed (the Position, Rotation and Scale buttons still determine if the motion channels are processed). This includes all envelopes applied to those items (like Camera Zoom Factor and Light Intensity), envelopes for applied plugins (such as Morph Mixer channels), and surface envelopes applied in the Surface Editor. Use this feature carefully, especially when deleting keys on multiple items at once.

The About button will open an informational dialog, including a list of keyboard shortcuts.

Delete Mode

The Delete Mode determines what is done to the item’s motion. The default mode, Delete Key, deletes the key at the frame entered in the Delete Keys field From field. Both integer and fractional keyframe values can be entered.

The Threshold field can be used to determine how close a keyframe has to be to the defined frame to be deleted. This is useful for deleting fractional keyframes when Fractional Frames is disabled on the General Options Tab of the Preferences Panel.

If all keyframes become deleted in any of these modes, a new default keyframe is created at frame 0 with a position and rotation of 0.0 on all axes, and a scale of 1.0.

Threshold

Threshold determines how close a keyframe has to be to the From and Through frame numbers in order to be deleted. The default value of 0.0 means that the key must exactly match the frame numbers entered. A value of 0.1 means that any keyframe within 0.1 frames will be deleted. For example, if you are trying to delete keyframe 20 with a Threshold of 0.1, all keys between 19.9 and 20.1 will be deleted. A value of 0.5 can be used to ensure that any fractional keys between the current frame and the next or previous frames are deleted without going into the domain of the next keyframe. The small pop-up menu to the right of the Threshold input field contains a number of reasonable presets values.

Protection

The Protection pop-up menu can be used to ensure that certain important keyframes are not deleted. This is especially useful when using the Delete Keys Outside Range or Clear Motion modes, where deleting all keyframes could ruin your scene or destroy your character’s bone setup and IK poses.

Saving and Loading Motion Files

To save the selected item’s motion path to a file, choose File > Save > Save Motion File. Use the filename extension .mot when saving a motion file. Mac users should note that this extension is not automatically added - you must type it as part of the file name and then save the file. To load a saved motion file and apply it to the selected item, choose File > Load > Load Motion File.

Modeler’s Path Extrude and Path Clone commands use these files to execute their operations.

DopeTrack

BioVision Motion Capture Support

LightWave provides a couple of plugins to support the BioVision (BVH) motion capture file format. The MoCap_BVH_Setup generic Layout plugin (File > Import > MoCap_BVH_Setup) reads a BioVision BVH file, creates bones, and applies the motion capture data to them. For any use of Motion Capture files, you will need to have AutoKey (Shift F1) enabled.

Set Start Frame Offset to the frame you want the motion to begin.

Bone Scale Factor allows you to set a scale for your object from the start and may need some repeated experiments to get close to the scale of your object. Often BVH files come in at an extremely large scale. As a start, try a scale of 0.1.

The Bone Name Postfix is simply a number appended to the end of all of the bone names (e.g., LeftKnee_1).

After you run the plugin, replace the top null (in the created bone hierarchy) with the object to be animated. You could also use the Use Bones From Object feature on the Bones Properties Panel.If you need to change the initial resting position of bones, make sure you reset their rest positions (use the r key). You’ll probably need to adjust some of the individual bone properties after you run the plugin.

Applying motion capture to a LightWave object is an arduous process fraught with difficulties but yields good results.

MoCapSkelegons is a Modeler plugin that creates skelegons in Modeler that match the initial rest position of the Biovision BVH data. Use it to determine the correct scale, position, etc. for your object mesh. This object can then be used with the bones created using the MoCap_BVH_Setup generic plugin in Layout.

Motion Preview

There is also a custom object plugin that can be used to preview BioVision motion data. The preview is fast and accurate. Use it to determine if there were any errors in the motion conversion.Simply add the MotionCapturePreview custom object to a null object on the Object Properties Panel. (If you run the MoCap_BVH_Setup generic Layout plugin, a null called “MotionCapturePreviewNull” will automatically be added to the scene with the custom object plugin already applied.)

Keyframer

Modify

Now we shall examine the Modify tab:

Light Intensity

(default keyboard shortcut Ctrl H)

Selecting a light, or several for that matter, and using this tool allows you to adjust light intensity interactively by holding down the LMB and moving the mouse left and right. Feedback is given down in the bottom left corner as usual. If you adjust more than one light at once, the feedback area reports how one is being adjusted, but all that are selected are adjusted equally. Make sure you multi-select with the Shift key rather than making a banding box.

MDD Multi-Loader

The MDD workflow is central to using LightWave in a multi-product pipeline, or to enforce consistency when network rendering. LightWave has long been able to save and load MDD files and this new window makes them much faster and easier to apply scene-wide. On the left side of the window are presented the objects in your scene with their point counts. The list on the right will hold the MDD files you load using the Add MDD file(s) or Scan Folder buttons. Once you have objects on the left and MDDs on the right you can either assign by hand, clicking on the object in the left list first, then the MDD; or you can use one of the automatic matching routines:

Following the Match By... options there are three other buttons.

All of the Name options respect the Name Match Tolerance percentage field under the left object name field. At its default 0% assigning MDDs is based on a strictly exact name match. Increasing this percentage will match more and more items to 100% where everything will be matched.

To the right of this field is Ignore Clone Suffix. This is checked by default since you often need to assigned MDDs to cloned objects. If you wish to control which MDDs get assigned to which of your cloned objects uncheck this button.

Once matched a tick will show by the object name in the left list. Clicking on an object with an MDD assigned will highlight the MDD it has been assigned in the right list. You can assign a different MDD by clicking on it in the right list and you can Remove MDDs by clicking the button with the same name, or Clear All MDDs by clicking the button to its right. This presents a warning before clearing the entire list of MDDs from the right list.

Under the MDD list on the right side of the window are the same options you will find in the MD Reader you will have used previously in LightWave for going through each object in the scene one by one. There are Random Frame Offset and Random Replay Speed buttons with ranges beneath each to allow you to apply some randomisation automatically across MDDs rather than needing to each individually.

The last two buttons are:

When you hit OK, the MD Readers are applied to the objects as in previous versions of LightWave.

Example - MDD Loader

 

Nodal Metalink

Users that have been LightWave artists for a long time will be familiar with the Metalink functionality for creating a simulation with a low polygon mesh and then using that simulation to drive the motions of a higher quality mesh. LightWave 11.5 introduced a nodal way of metalinking objects together. To use it, simply visit your high polygon mesh’s Object Properties window, the Deform tab and click Edit Nodes. Choose Displacement > Metalink and select the low polygon mesh you have used for the dynamics simulation.

The Metalink node can’t handle a lowpoly SubPatch mesh that was used for dynamics simulation linked to a highpoly SubPatched or polygonal object unless the lowpoly SubPatched object is set to a Display level of 0, but this shouldn’t prove much of a limitation.

 

 

LightWave's many tools for animation include not only the FK and IK sort, but also more procedural animation types, like Spline Control and Raycasting.