Modeler has two Options windows, General and Display. It also uses the same Keyboard Shortcut, Configure Menus  and Edit Plugins windows as Layout.

General Options

(default keyboard shortcut O)

You can access the General Options Panel by choosing Edit > General Options.

General Tab

OBJ Tab

The OBJ tab contains options for importing and exporting OBJ file objects.

  1. OBJ One Layer - imports the object as a single layer.
  2. OBJ One VMap - imports the object with a single vertex map.
  3. OBJ Pivot at Center - creates the pivot of the object at the center of the object.
  4. OBJ Write Normals - writes the normals associated with the object when saved.
  5. OBJ Merge Points - merges points sharing the same space.
  6. OBJ Reverse Ka & Kd - Reverses Ambient Occlusion and Diffuse channels.
  7. OBJ Double Sided - Creates double-sided geometry.
  8. OBJ Parts - Keeps LightWave Part Polygon tags.
  9. OBJ Foreground Layers - Only saves layers marked as foreground to OBJ.
  10. OBJ Continuous UV - UVs have shared points rather than duplicated.
  11. OBJ Import Scale - sets the scale of an object when it is imported.
  12. OBJ Export Scale - sets the scale of the object when it is exported.

Color Space Tab

Color space conversion is performed in four places in LightWave.

  1. On loading, an image can be converted from its native color space format to linear.
  2. When sent to the Image Viewer, an image can be converted from linear to another color space.
  3. When saved from the renderer, an image can be converted from linear to another color space.
  4. When picked from the Color Picker, a color can be converted from and then to linear color space.

The color space defaults are set up on the Layout Preferences panel.When an option is selected in the pop-up it becomes the current item for that selection.

Color tables are added to the selections, as if they were built-in.

A color table can be loaded by using Load Table from the pop-up. The color tablesare stored in the project directory, in a directory called Color Tables.

In the Image Editor, there is a check box, Treat as Alpha. This means use the alpha channel from the Preferences Default setting, not the alpha channel from the color space in the Image Editor. This is an override on the alpha color space selected in the Image Editor.

One can set the color correction for the Viewer files with palettes, 8-bit files, floating point files, alpha channel and the color picker from the preference default panel and the Modeler General Options panel.

When an image is loaded, if the file setting for that image is set to default, then an attempt is made to look at the metadata setting for that image. If the metadata settings have the color space the image was saved in, then it is used. For example, jpegs have metadata setting for sRGB and Adobe 1998 linear format.

The built-in color spaces are:

  1. Linear, LightWave linear color space.
  2. sRGB, Standard RGB color space.
  3. rec709, BT.709, HDTV
  4. Cineon, Eastman Kodak Co.

The color lookup tables come in two formats:

  1. LightWave color table format.
  2. 3D LUT format.

LightWave color table format is as follows:

Code:

EGA
17, -0.5, 1.5
; Convert on load.
-0.5, -0.5, -0.5, -0.5
-0.375, -0.375, -0.375, -0.375
-0.25, -0.25, -0.25, -0.25
-0.125, -0.125, -0.125, -0.125
0.0, 0.0, 0.0, 0.0
0.125, 0.125, 0.125, 0.125
0.25, 0.25, 0.25, 0.25
0.375, 0.375, 0.375, 0.375
0.5, 0.5, 0.5, 0.5
0.625, 0.625, 0.625, 0.625
0.75, 0.75, 0.75, 0.75
0.875, 0.875, 0.875, 0.875
1.0, 1.0, 1.0, 1.0
1.125, 1.125, 1.125, 1.125
1.25, 1.25, 1.25, 1.25
1.375, 1.375, 1.375, 1.375
1.5, 1.5, 1.5, 1.5
; Convert on save.
-0.5, -0.5, -0.5, -0.5
-0.375, -0.375, -0.375, -0.375
-0.25, -0.25, -0.25, -0.25
-0.125, -0.125, -0.125, -0.125
0.0, 0.0, 0.0, 0.0
0.125, 0.125, 0.125, 0.125
0.25, 0.25, 0.25, 0.25
0.375, 0.375, 0.375, 0.375
0.5, 0.5, 0.5, 0.5
0.625, 0.625, 0.625, 0.625
0.75, 0.75, 0.75, 0.75
0.875, 0.875, 0.875, 0.875
1.0, 1.0, 1.0, 1.0
1.125, 1.125, 1.125, 1.125
1.25, 1.25, 1.25, 1.25
1.375, 1.375, 1.375, 1.375
1.5, 1.5, 1.5, 1.5 

Where:

 

Display Options

(default keyboard shortcut D)

Modeler’s interface is highly configurable allowing to tailor it to your specific needs. You can change the arrangement of viewports as well as change the display characteristics for each viewport independently. Choose Edit  > Display Options  to bring up the Display Options Panel.

Layout Tab


Layout options control the global arrangement of the viewports, the number of viewports and some other Global Display settings. Use the Presets pop-up menu to quickly set common layout configurations (Quad is the default setting). Selecting a Preset will affect the Layout setting, as well as settings on the Viewports Tab.

If you want to set up your own custom layout, make a selection from the Layout pop-up menu. The icon to the left of the description will give you an idea of how the viewports will be arranged. Later, you will see that you have total control over what is in each viewport. In fact, each Layout option will remember the Viewport settings as they were the last time that Layout option was used.

Show Options

The various Show Visibility options let you independently set what you want to see globally in your viewports.

These visibility options can be overridden independently for each viewport on the Viewports Tab.

GL Tab

Viewports Tab

Viewport options let you change how objects are displayed in each viewport. To change the settings for a viewport, first select it using the Viewport buttons.

Use the Presets pop-up menu to quickly set the options on this tab for the selected viewport region. The selections are listed by view types, but will affect all of the settings on this tab.

The View Type pop-up menu determines the editing axes you want to use for the selected region.

For the Orthogonal settings, the names generally indicate the viewing perspective. Back (XY), for example, lets you edit along the X and Y axes. This means you are looking along the Z axis.

Since it is called Back, that means your perspective is from the back (i.e., negative side) of the Z axis, looking toward the positive side. UV Texture is entirely different - it is not used as a Modeling viewport but for adjusting UV texture maps.

There are four Display (group) commands assigned by default to certain keyboard shortcuts which affect the viewport beneath your mouse pointer. Shift F1 toggles the view between Back and Front, Shift F2 toggles between Top and Bottom, Shift F3 toggles between Right and Left, and Shift F4 toggles between Perspective and UV.

Perspective

You may edit in a Perspective viewport, just as you would in any other, but you may also rotate your view perspective. This is Modeler’s virtual trackball, which enables you to rotate the object without affecting its orientation in the other three edit windows. It effectively provides you with three axes of rotation. While holding down the Alt key, you can perform these actions:

If the title bars are visible, you can drag the rotate drag button with your LMB to rotate. If you use the RMB, the viewport will rotate around its perpendicular axis. Holding the Ctrl key (or using your MMB) will cause rotations to snap to 15-degree increments.

Imagine you are manipulating an imaginary ball with your mouse when you manipulate the Preview window.

Titlebar Shortcuts

You can change the View Type and Rendering Style of a viewport without going to the Display Options Panel by using the pop-up menus on the title bar. Clicking on the left-most pop-up allows you to choose which View Type you want to be in and will then display it. The pop-up menu just to its right lets you choose the Rendering Style.


Note that if you have UV Texture selected as the View Type, the Rendering Style pop-up menu will instead list all loaded images. Select one to load it into the backdrop of that viewport.

Independent Options

The Independent options let you make certain viewport characteristics independent from other viewports. Changes to the selected characteristic do not affect it in other viewports and vice versa. For example, if a viewport uses Independent Zoom, zooming in it does not affect the zoom of other viewports. You must have your pointer over the viewport to affect an independent viewport. Independent Rotation is only applicable to perspective views. Normally, it is enabled. If you have multiple perspective views and this option disabled, they will move in unison when you rotate a view.

Independent Visibility

The lower portion of the panel contains the independent visibility options. You can individually select which visibility options are independent. To use them, you must also activate the Independent Visibility option. This option lets you quickly enable/disable this feature without losing the state of each setting.

Backdrop Tab

On the Backdrop Tab, you can add full-color backdrop images that act as reference guides when you build objects. They let you model much like tracing a picture using tracing paper. To use backdrops, select the Viewport and the desired image from the Image pop-up menu.

If you are using a UV Texture viewport, you can choose a backdrop using any loaded image from what is normally the Rendering Style pop-up menu on the viewport’s title bar.

From the Presets pop-up menu, you can save the settings for the selected Viewport to a file by choosing Save Current Backdrop. You can load this file later using Load Backdrop for any selected Viewport. You can also save the settings for all viewports by choosing Save All Backdrops. When this file is loaded later - using Load Backdrop - the individual Viewport settings are restored.

The backdrop images for the current default layout for each view configuration are cached as long as possible. Also, backdrops are not saved in config files or view presets.

Use the Image drop down menu to select from the loaded images or choose (Load Image) to bypass the Image Editor and load a new image into Modeler and automatically select it for the current viewport.

You can also adjust Brightness and Contrast. Use the sliders to adjust the settings. You can invert the colors by activating the Invert option. If you want to blend pixels for close-up work, activate the Pixel Blend option. Image Resolution determines the accuracy of the displayed image.

Colored background images sometimes make the wireframe hard to see (especially if the image has a bright white background). Setting the Contrast to its lowest value, and the Brightness to a little above the darkest value will produce a reasonable-looking backdrop that works well when Modeling.

Aspect and Video images

The two Center and Size input fields are horizontal (top field) and vertical (lower field). Clicking Automatic Size will enter values that fit the defined image into an implied bounding box that surrounds visible geometry.

If you activate the Fixed Aspect Ratio option, you can enter a frame aspect ratio in the input field. Then, you only need to specify a horizontal size - the vertical size is computed automatically. If your images originated from video, you need to account for the pixel aspect ratio, since video pixels are not square like computer pixels. For example, a D1 NTSC image is 720 x 486 pixels; however, the frame aspect ratio is not 1.48 (720/486) as you might expect. The width of a D1 NTSC pixel is 90 percent of the width, that is, a pixel aspect ratio of .9. As such, the true frame aspect ratio is 1.333 (720/486*.9).

The frame aspect ratio of a D1 PAL image is also 1.333 (720/576*1.067).

If you do not account for this difference, your models may appear slightly stretched when ultimately viewed on video. A way to fix this is to scale the object after the fact.

Interface Tab


The Alert Level affects how error, warning and informational messages are displayed. The Toolbar Position setting determines if the main toolbar appears on the Left or Right side. Activate Hide Toolbar to make it hidden and maximize your screen real estate. Alt +F2 will hide (and more importantly, Unhide) the Toolbar as well.

Toolbar On/Toolbar Off

The Viewport Titles option turns the titlebars, which appear above each viewport, on or off.

Toolbar On, Viewport Titles Off

Use the Input Device buttons to select the type of input device you are using.

New to LightWave 2015, you can optionally set Mouse Wheel Zoom to enable the use of the mouse scroll wheel to zoom in and out of a viewport. As with using the Ctrl Alt shortcut, the view will zoom based on your mouse pointer’s location.

The next option is for Double-click Deselect, also new to 2015. This gives you the possibility to double-click on any empty space in the Modeler interface to deselect all selected Points, Edges or Polygons. You will still be able to use a single click in the normal deselect areas (under the menu buttons, on top of viewports, etc.) will this option is engaged.

The Fine Detail Cursor option, when active, makes your mouse pointer use the main crosshair pointer at all times instead of changing when the various tools and selection functions are used.

The File Dialog pop-up menu lets you use custom LightWave dialogs for file loading/saving. Selecting Default will use your standard system dialog.

 

The custom File dialog provides many additional features not available with the standard system dialogs.

The Visual Browser - You can make the LightWave visual browser the default file dialog for Layout and/or Modeler by choosing VBFileRequester on the File Dialog pop-up menu. This appears on the Interface Tab of Modeler’s Display Options Panel (Edit > Display Options).


The Color Picker pop-up menu lets you use custom LightWave dialogs for picking colors. By default it is set to the LightWave color picker shown below, but if you wish you can choose the system color picker here.


The Color Format setting determines the scale used where the color selector appears. Integer uses values 000 to 255, Float uses .00 to 1.00 and Percentage uses 0% to 100%.

The Simple Wireframe Edges option turns off polygon offsetting for the sketch-like display modes. This may fix display problems on some video cards. The Simple Wireframe Points setting uses OpenGL’s own points for wireframe points and selected points at a user-specified size. These points can draw much faster than the standard points.

Units Tab

The Unit System determines the units of measurement that are used and displayed by the Modeler screen.

We recommend you use the SI or Metric systems to model objects, since a system using base 10 is often much easier to use for purposes such as applying textures and adjusting object movement.

If you input a value that uses a different unit of measurement than that of the default, LightWave will convert it on the fly. For example, you may be using meters, but typing in “5 ft” will convert to “1.524 m.”

    1. 1 - The grid resizes in values that begin with 1, as in 10m, 1m, 100mm, 10mm, etc.
    2. 1 5 - The grid resizes in values that begin with 1 or 5, as in 1m, 500mm, 100mm, 50mm, 10mm, etc.
    3. 1 2.5 5 - The grid resizes in values that begin with 1, 25, or 5, as in 1m, 500mm, 250mm, 100mm, 50mm, etc.
    4. 1 2 5 - The grid resizes in values that begin with 1, 2, or 5, as in 1m, 500mm, 200mm, 100mm, 50mm, etc.
    5. 1 2   - The grid resizes in values that begin with 1 or 2, as in 1m, 200mm, 100mm, 20mm, 10mm, etc.
    1. None - None deactivates grid snap, so that items move freely and are not constrained by any grid intersections.
    2. Standard - Standard sets the grid snap to one-tenth of the current grid size.
    3. Fine - Fine makes the grid snap as small as possible for the current zoom level. This will be typically two to five times smaller than using Standard.
    4. Fixed - Fixed lets you specify the increment of movement in the Snap Value input field. The grid will resize itself to use the value you specify.